Verification Errors
Incident Report for Keycafe
Postmortem

A brief maintenance was required to address the problem.

Posted about 1 year ago. Oct 04, 2018 - 22:20 UTC

Resolved
Some users are reporting a problem verifying their email address or phone number.
Posted about 1 year ago. Sep 20, 2018 - 17:30 UTC