Third-party provider wide-spread issue
Incident Report for Keycafe
Resolved
Or service provider has resolved a network issue that affected multiple services across the internet. Our website has returned to normal operation.
Posted Jun 21, 2022 - 07:42 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 21, 2022 - 07:35 UTC
Update
They have implemented a fix and are now monitoring the results.
Posted Jun 21, 2022 - 07:25 UTC
Monitoring
A third-party provider Cloudflare has discovered a widespread issue with their service impacting our Website. We are monitoring.
Posted Jun 21, 2022 - 07:22 UTC
This incident affected: Website.