Partial outage - Cellular network

Incident Report for Keycafe

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 12:46 UTC

Identified

Some cellular devices are experiencing connectivity issues. Our service partner is working to stabilize connections. We will continue to monitor their progress.
Posted Jul 03, 2025 - 10:01 UTC
This incident affected: SmartBox.